Jump to content

Crosswalk and Phaser


Recommended Posts


I'm trying to put my Phaser game in a Crosswalk/Cordova Android wrapper. I've been following the steps described: 

https://crosswalk-project.org/documentation/cordova/migrate_an_application.html, and been using the versions mentioned there (Cordova 3.5, Crosswalk 7.36). I've also tried the newest versions of both.

When running the app in the Android emulator, I end up with a black screen and this error in the console:


Uncaught Error: This browser does not support webGL. Try using the canvas renderer[object Object]


That's when I set the rendering mode explicitly to webGL. When using Phaser.AUTO, canvas mode gets enabled.

navigator.userAgent in the console returns:


"Mozilla/5.0 (Linux; Android 4.4.2; sdk Build/KK) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.125 Mobile Crosswalk/ Mobile Safari/537.36"


So it seems Crosswalk is indeed being used. I'm using Phaser 2.1.1.

I tried using 'deviceready' as my entry point for initiating the game, but it doesn't seem to make much difference.


Any ideas anyone?


Best regards



Link to comment
Share on other sites


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...