Jump to content

Can't seem to be able to render text


mikehamil10
 Share

Recommended Posts

Hi!

 

First off great job on Phaser so far. It's shaping-up to be a great HTML5 engine.

I am, however, having an issue with rendering text. It just doesn't seem to work :(

 

Looking through the files in the WIP folder I found some text examples. When I run them, I get the following error:

  1. Uncaught TypeError: Cannot read property 'size' of undefined inBitmapText.js:82

 

That bit of code seems to be trying to read a property called data.size, which is obviously null. I don't know much about Pixi.js, but on line 75 where the data object is created, I think something is going awry. I'm using Phaser.CANVAS for my rendering mode, and the name of the font I'm passing-in is just "Arial". I should also note that I get the exact same error when I try to create text in my own projects, so something's going on there.

 

Any help getting custom text to render would be greatly appreciated, and keep up the good work!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...