Jump to content

babylon plugin issues and model texture problems

Recommended Posts

hii all 

i downloaded babylon plugins from github source link : https://github.com/BabylonJS/Babylon.js so there are multiple issues that i faced when i am using plugins or when exporting which i need to solve/understand about the technicalities  so what are the problems 

plugin issues

1) i installed 3ds max plugin (my software version 3dsm 2013) but  plugin is not installing correctly i followed the exact steps that are mentioned in the download link but these errors are coming and 3ds max is not accepting that plugin when i tried to import it.. refere screen shots (1  & 2 screen shots)

2)  and about blender plugin (blender 2.66) installed and imported obj to blender and tried to export that model to babylon from blender but we get notepad out of it about saying that model exported successful but only thing exported is notepad so whats there in that basically info about the model nothing else 

3)installed babylon exporter plugin in unity (unity ve 5.3.2 f1) and works fine but some issues that i faced please refer screen shot model exported and for textures i mapped it into 1 texture image  i got some issue in texture here is the screenshot of the problem when i was testing it in babylon sandbox (black boxes are coming) so my doubt is -is that because of single texture image ?-- (3rd screen shot)

plugin problem.jpg



Link to comment
Share on other sites

Hello and welcome!

1. I did not test support for 3dsmax design. But beforehand, did you unlock the dlls as mentioned in the doc?

2. I do not understand :) What do you mean by notepad?? THe .babylon should be where you asked it to be

3.If you check the logs in the lower left part of your screen you will get your answer: one file is missing :)

Link to comment
Share on other sites

hii @Deltakosh! :)

1.yea i :) have gone to properties and unlocked it thats it ..
2. so... after installing plugin in blender when i exported the model to babylon i will not get any output file from blender 
3.so unity plugin is working.... and actually i optimized everything into 1 single texture and as u can see in the above screen shot that texture is applied but black blocks are coming 

Link to comment
Share on other sites

I would make certain that all of your surfaces are 3 sided polygonal - just for a test to be certain your scene doesn't contain unsupported surfaces or splines. Also, test using power of 2 textures - again, you don't need to do these two steps for your actual export/import, but these will rule out 2 common errors users often make. This might also provide you with additional information from your results as well.

As for Blender, I've never pressed the export button and not output a .babylon file - however, I have sent it to the incorrect path a few times unknowingly.


Link to comment
Share on other sites


Blender 2.66 is way too old, like 2012.  2.77 is actually required for TOB 5.0, when it comes out.  The next version actually checks the Blender version against the version listed in the bl_info structure.  If not that version or greater, export terminates, not even trying.

Blender is a free program, so should not be too big a deal.

This may still be a problem, since the blend file has been written with 2.66.  Do a save as with Blender 2.77, as a first remedy, in tho case.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...