Jump to content

[SOLVED] Scene.executeWhenReady never called on SceneLoader.ImportMesh if renderTargetTexture was disposed


Recommended Posts


I have a scene with a renderTargetTexture (a reflectionProbe to be precise). The scene is fully loaded, everything is fine in a calm and peacefull world.

Then, I suddenly decide to load new meshes, via SceneLoader.ImportMesh. In the succes callback I'm using scene.executeWhenReady to do some post treatment.

And again, everything is fine, the scene goes well, the new meshes live their lifes quietly in a stable universe and the gods are happy.

But if at some point I disposed the probe before loading those new meshes, the scene.executeWhenReady is not called!

I tried disposing manually the renderTargetTexture inside the probe and the problem also occurs, it is clearly related to renderTagetTexture disposal, as if some flag was forgotten somewhere, leading to scene never ready again.

The case where this bug occur is pretty specific so I do not have a repro case in PG for now. But maybe with the information I gave that would make someone here have a "tilt"...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...