Sign in to follow this  

NPM Install Issues

Recommended Posts

I would love to know how come npm install doesn't work on a mac. I have tried numerous times during the last months, when it was still in beta.

I am running sudo npm install phaser@3.1.2 and I always get the following issues, also I am using node v8.9.4


I know they are just warnings, but nothing is in my local directory. I have also tried with the --save flag. I checked the global location just in case and there is nothing there either


xxx-MacBook-Pro:phaser3 xxx$ sudo npm install phaser@3.1.2


npm WARN saveError ENOENT: no such file or directory, open '/Users/xxx/package.json'

npm WARN enoent ENOENT: no such file or directory, open '/Users/xxx/package.json'

npm WARN xxx No description

npm WARN xxx No repository field.

npm WARN xxx No README data

npm WARN xxx No license field.


+ phaser@3.1.2

updated 1 package in 2.42s

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.