Jump to content

'This.frame is undefined' when using dynamicTileMapLayer.setDisplaySize


Babsobar
 Share

Recommended Posts

Hello,

I'm trying to use setDisplaySize method on a dynamicTilemap layer but I'm getting a 'this.frame is undefined' when trying to set it. It's supposed to take a width and a height as parameters as shown here.

I've tried setting it to a frame but it returns the same error.

. I believe this may be linked to the problem I've encoutered and posted about in this thread but I'm not sure.

Any help much appreciated

 

Link to comment
Share on other sites

Hello rich,
Happy that I caught an actual live bug, that would be my first!
 

1 hour ago, rich said:

Be aware that setDisplaySize sets the size of the entire map, not just the area visible in the camera.

So how would I go about setting the area visible in the camera? I've been trying to figure how to for days,  zooming out using the camera doesnt show more of the dynamicTilemapLayer.

Thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...