Jump to content

Doesn't work on iPad


Biggerplay
 Share

Recommended Posts

I've updated my game code from 1.1.3 to latest version of Phaser and it runs fine on desktop, but when I run it on the iPad it runs the preloader and then just stops.

 

Are there any major things with the new version which stop it working on the iPad? I'm just curious if there's any of the changes which cause iPad issues, so I can go in and try and fix it, but apart from that if it's working on the desktop I'm not sure what would cause it stop on the iPad after the preloader stage.

Link to comment
Share on other sites

I tracked it down to this in the preloader file

 

if (this.cache.isSoundDecoded('titleMusic') && this.ready == false){  this.ready = true;  this.game.state.start('MainMenu');}

Those conditions seem to be never met on the iPad, but are on desktop. So I moved the state.start into the create function and it works, but there's no sound on the iPad version.

 

And it still doesn't work on the iPhone, just same as before preloader bar goes up to the top, and then it stops.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...