Recommended Posts

Hi,

How about an option in vrHelper to force the height of the camera, even if isInVRMode is true ?

I'm testing my scene seated, but I want to be in a stanted view inside my VR.

So it will be nice if we have a forceDefaultHeight option in webVROptions, to always be standing

Thank you !!

Share this post


Link to post
Share on other sites

Which headset/browser are you using? I believe Vive or Occulus currently use actual height from the ground instead of using the default height set in the constructor when teleporting. For debugging you could hack this now by setting the hidden field _standingMatrix to null. See this playground: http://playground.babylonjs.com/#NPW39S and let me know if that doesn't work.

If I understand your issue correctly and the above fixes it we could add a flag to disable using standing matrix even if its populated by the headset for your scenario.

Share this post


Link to post
Share on other sites

I'm using htc vive and firefox. I'm teleporting with gamepads.

I can't test in PG because I can't make teleportation work inside it... I don't know why... Even with:

helper.enableTeleportation({floorMeshName: ground});

But yes, you correctly understood my issue.

For example: if I was developping a game like a FPS, I can play seated, but in my game, I want to be in standing view...

Share this post


Link to post
Share on other sites

I tried the Mansion scene, and the teleportation doesn't work in the PG neither. But interactions with GUI and controllers works fine..

It look like it doesn't reconize the floor mesh..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.