Glitchy Phaser examples

Recommended Posts

Hi everyone!

I am quite new to Phaser and javascript and I have been learning it mainly with the examples and library.

During my explorations I noticed that some examples do not work when downloaded to my computer (or even my friends' as well), but it does on the phaser page.
As an example: - when downloaded to my computer the characters are constantly jumping and going everywhere without any pressed key (video of the glitch).
Also, the when opened it just show an empty canvas. When I ran the web console it states 2 errors: the 'game.rnd.between is not a function' and 'sprite is undefined'.
These examples were downloaded straight from the page.

Am I doing something wrong when testing these examples?
I usually create a folder with the assets folder, index.hmtl file, phaser.min.js and sourceexample.js. The files are linked on the html file.

Am I missing something or is it just the case these codes are faulty and incorrect from the source?

I am running out of ideas here and any help would be much appreciated. :)

Share this post

Link to post
Share on other sites
On 10/9/2018 at 11:51 PM, rich said:

Which version of Phaser have you put with them? It says in the console when run.

I just checked, it was a really old version (2.0.1). I just updates to the last phaser 2 version and the custom-sprite-vs-group example worked. 🙌 Newbie mistake. 😅

I tested this new version with the ninja-platforms example but the glitch persists. Any ideas why this glitch keeps happening? 🤔

Thank you!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.