michagoose

GPU Particles & Blend Mode

Recommended Posts

I’m trying to optimize my babylon scenes using GPU particles, but If I use the same blend mode as I had with standard particles (BLENDMODE_MULTIPLYADD), then my particles look terrible with the transparent portion being ignored. If I use BLENDMODE_STANDARD the particles come out looking too dark. Is there a way to have the same look when I’m using both GPU particles and non-GPU particles?

Here’s a playground with my settings and using my particle texture.

https://www.babylonjs-playground.com/indexStable.html#C1KYFM#2

 

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.