Jump to content

UnknownError encountered while rendering scene


Recommended Posts



I am confused because of an error I am encountering right now.

Here is the complete output in Firefox:

BJS - [10:13:36]: Babylon.js engine (v2.0.0) launched                                                        babylon...ebug.js (Zeile 2927)GET http://xxx/res/webgl/Mesh1.03.babylon.manifest?1425287616896'>http://xxx/res/webgl/Mesh1.03.babylon.manifest?1425287616896  200 OK 2ms                                babylon...ebug.js (Zeile 14169)GET http://xxx/res/css/stylesheet.css                             304 Not Modified 3ms                            hand-1.3.8.js (Zeile 725)GET http://xxx/res/webgl/Mesh1.03.babylon                         200 OK 55ms	                             babylon...ebug.js (Zeile 2594)UnknownError                                                                                             babylon.2.0.debug.js (Zeile 14195)var request = this.idbFactory.open("babylonjs", 1);

And here in Chrome:

BJS - [10:21:31]: Babylon.js engine (v2.0.0) launchedGET http://.../res/js/Babylon.js-master/babylon.volumetricLightScatteringPostProcess.js.map 404 (Not Found)   babylon.volumetricLightScatteringPostProcess.js.map:1

Except for adding comments to my Babylon code, I have literally not changed it in weeks now and it always ran without error.

Until last Friday I ran version 1.14 of Babylon, when I suddenly encountered this error. I then updated to version 2.0 but still have this error.


My scene is still rendered, seemingly without problems. Everything still seems to work. But getting this error without being able to find the cause is pretty grating.

Link to comment
Share on other sites

Regarding chrome - 


The Chrome error is simply a sourcemap file not found. It's not really an error.

Chrome tries to find the sourcemap file if it is declared in your javascript file. It actually only happens when you have your console open (try rendering the scene first and then opening the console, you will notice it is trying to load the map only then).


So, Tl;dr - alles ist in Ordnung, this is not really an error.


Regarding firefox - 

If you changed your babylon source code, it would be hard to tell you what's wrong in Zeile 14195, But it doesn't look like the same mapping problem. What's in this row?

Link to comment
Share on other sites

Let me clarify:

The code I personally wrote for Babylon, meaning creating a scene, adding a camera, lights, materials and importing a mesh has not changed in the last few weeks. But last Friday I suddenly encountered this error using version 1.14. I then updated to 2.0 but the error remained.

From what I can tell with my limited knowledge, while trying to open a Database asynchronously, if this has not happened Babylon then tries to create an indexed database and here something goes wrong. But don't take my word for it, I just tried to decipher the code based on function-names and comments.


Edit: I just finished testing with Firefox 35.0 and the error does not happen, so I am pretty sure it has something to do with the new Firefox version 36.0. It seems it updated on my system last friday, so that's why I encountered this error then.

Link to comment
Share on other sites

It seems this error is caused when I try to import a mesh into my scene.


In this case I created my mesh in 3dsmax, converted it with the babylon-plugin and imported it with "BABYLON.SceneLoader.ImportMesh(...);"


If I just add a normal box to my scene for example, I do not encounter this error.

Link to comment
Share on other sites

  • 1 month later...

So, after sitting on this problem for over a month, I tried to narrow down when the error appears.
This scene throws 3 such errors, when opened with the latest Firefox.
The first for:

BABYLON.SceneLoader.ImportMesh("", "res/webgl/", "Mug1.04.babylon", scene, function(newMeshes) {};

The second for:

inlayBackMaterial.diffuseTexture = new BABYLON.Texture("http://i725.photobucket.com/albums/ww255/Toushin/background_zpsmnkep3ya.jpg", scene);

The third for:

inlayForeMaterial.diffuseTexture = new BABYLON.Texture("http://i725.photobucket.com/albums/ww255/Toushin/Foreground_zpsskfkts3l.png", scene);

If I comment out lines 43 - 51 and 70 - 72, and instead create two boxes with these materials no errors appear. I believe, it therefore has something to do with the .SceneLoader.ImportMesh function I am using.


To prevent misunderstandings, I have not changed the babylon javascript file in any way and I am using "babylon.2.0.debug.js".

Also this same code to import a mesh worked without problems in an earlier version of Firefox, I believe 35.


The scene seems to render correctly, so I am unsure if I should simply ignore this error, but it still bugs me.

Help would really be appreciated.

Link to comment
Share on other sites

This doesn't really help me, since the textures are from an external website, in this case Photobucket.

And like I said, the textures throw no error, when I remove the .SceneLoader.ImportMesh function.

Just placing the code for the textures outside this function removes the errors for them, but the .SceneLoader.ImportMesh function still throws the error.


Also, I already tried changing the string for the rooturl parameter to "./res/webgl/", but this didn't help any.

Link to comment
Share on other sites

Your textures assigned to models from your modeling software should be present in the same folder as the model.


new BABYLON.Textures must be used to change after the existing textures, or to add a mesh which does not have textures.

Link to comment
Share on other sites

Are you sure Photobucket website has CORS enabled ? You cannot load a file from outside your server if the security policiy of the external server is not "open enough".

Maybe your problem is related to that (generally there is a CORS warning in the console when this occurs, but maybe not in your case, for unknow reason :mellow: ...).

Link to comment
Share on other sites

@dad72 My model does not use any textures at all. I just assign some meshes a new material which has a texture, which is from an external source in this example.


@Vousk-prod. Photobucket is open enough, because the textures are actually loaded and correctly displayed, so I don't imagine the problem lies there.


Let's please focus not so much on the textures, because in this case they shouldn't really matter so much. In fact, removing everything from within the BABYLON.SceneLoader.ImportMesh function and only having something like

BABYLON.SceneLoader.ImportMesh("", "res/webgl/", "Mug1.04.babylon", scene, function(newMeshes) {});

displays my model and throws the error.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...