Jump to content

iPad Air 2 compatibility


Recommended Posts

Hello everyone,


I tested the following link with



- firefox 36.0.1

- IE11.0.9600.17631

- Chrome 40.0.2214.115


and they all work



- Chrome 40.0.2214.109

- Firefox 36.0


and the all work


iPad Air 2:

- Safari  (don't know what vresion, but I have the latest iOS installed)

- Chrome 40.0.2214.73


both don't work


Can you help me with iPad?


here is the link:




Thanks in advance

Link to comment
Share on other sites

Haven't got access to my ipad at the moment (girlfriend fell asleep with it reading reddit). Does any of it load or just part of it? I have an issue wit the ipad mini at the moment and wondering if maybe if its to do with the model in the scene, and if so what in the model is not allowing it to work on the ipad. 

btw, the scene is doing some really strange stuff in your example when viewed and rotated on a pc. Its as though the 'walls' are following the controls and cut off parts of the models as you rotate.

Link to comment
Share on other sites

I have an iPad Air 2.  Just see a yellow box & 3 buttons, which do not do anything.  You know this of course.


The test I just did was also run this on OSX, Safari.  Same thing.  Hard for me to comment more, since I do not know what it is supposed to do, but just thought I would share the data point.


I had been mostly testing using CocoonJS on the Air 2, but the occasional thing i clicked while viewing this forum had always worked.


Just power up my Linux system, and see what it is supposed to do there.  Assumed it worked there, unless I reply again.

Link to comment
Share on other sites

I don't know how to do it. But I have been able to test it on a macbook air with Safari 6.1 and enabling developer tools I saw that safari tries to download the manifest of the babylon file, but I haven't it because the model is from a blender export and it didn't create the manifest


So please, tell me how to do what you asked me to do and tell me if there is a way to obtain the manifest file or how to create a valid one


Thanks in advance

Link to comment
Share on other sites

Shame on me!


I didn't see there was a debug version of the library...


Well, using the debug library, it works! Using the release library it doesn't work :(


Any idea?


Here, you can find both links:






the only difference is the babylonjs called...

Link to comment
Share on other sites

This does not put it in the render loop.


this.scene.debugLayer.show (); // V 2.0


but you can use if(scene.isReady()) to check that everything is ready before.


and in the render loop you should not use this, but as That explain another of your topic

Link to comment
Share on other sites

Yeah, i have put the line in the render loop because i wanted to be sure that it was called somehow... ehehhe


Now I have put it in another place and i did this:

if (this.scene.debugLayer != undefined)	this.scene.debugLayer.show ();

So I can use the same code with both libraries, release and debug.


However I still don't know why with debug library on the ipad it works and with the release library it doesn't... :(

Link to comment
Share on other sites

I did what you suggested.


Of course is not your fault, but on the ipad, now it doesn't work anymore even the debug version.


However I receive this error doing remote debugging on the ipad

[Error] TypeError: undefined is not an object (evaluating 'window.performance.now')
    get (babylon.js, line 3)
    _MeasureFps (babylon.js, line 3)
    beginFrame (babylon.js, line 3)
    _renderLoop (babylon.js, line 3)
    (funzione anonima) (babylon.js, line 3)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...