Jump to content

Can't export from Blender to Babylon.js


Recommended Posts

I'm trying to export any file from Blender using File - Export - Babylon.js and I get this error message.


Any help would be very much appreciated!

	Exporter version: 3.0.0, Blender version: 2.70 (sub 0)========= Conversion from Blender to Babylon.js =========	Python World class constructor completed	processing begun of mesh:  Cylinder.004		processing begun of Standard material:  Material.028		num positions      :  66		num normals        :  66		num uvs            :  0		num uvs2           :  0		num colors         :  0		num indices        :  384	processing begun of mesh:  Sphere.006		processing begun of Standard material:  Material.033		num positions      :  529		num normals        :  529		num uvs            :  0		num uvs2           :  0		num colors         :  0		num indices        :  3096	processing begun of mesh:  Sphere.005		processing begun of Standard material:  Material.027		num positions      :  994		num normals        :  994		num uvs            :  0		num uvs2           :  0		num colors         :  0		num indices        :  5952	processing begun of mesh:  Sphere.004		processing begun of baked material:  Sphere.004========= An error was encountered =========  File "/home/fariazz/.config/blender/2.70/scripts/addons/io_export_babylon.py", line 287, in execute    mesh = Mesh(object, scene, nextStartFace, forcedParent, nameID, self)  File "/home/fariazz/.config/blender/2.70/scripts/addons/io_export_babylon.py", line 695, in __init__    bakedMat = BakedMaterial(exporter, object, recipe)  File "/home/fariazz/.config/blender/2.70/scripts/addons/io_export_babylon.py", line 1803, in __init__    bpy.ops.uv.smart_project(angle_limit = 66.0, island_margin = 0.0, user_area_weight = 1.0, use_aspect = True)  File "/usr/share/blender/scripts/modules/bpy/ops.py", line 188, in __call__    ret = op_call(self.idname_py(), None, kw)ERROR:  Converting py args to operator properties: : keyword "use_aspect" unrecognized========= end of processing =========elapsed time:  0 min, 0.1385 secs

This is version 2.72 of Blender (the one required for the Babylon export script) in Ubuntu.


I've tried exporting a new Blender project with no edits, also tried this public domain one Japanese House | Blend Swap and many others, always getting the same "use_aspect" error message.

Link to comment
Share on other sites

Well fariazz, I looked at the Japanese House from Blend swap and at the log above.


The exporter does fine with with the first three materials - they do not have textures associated with them.


Then it hits mesh Sphere04 - which does have a texture associated with its material - pillowfabric.jpg. Unfortunately, this texture is not being loaded (see image below - right red box)


In fact there seem to be at least 5 textures not being loaded (left red box)


If textures are somehow copyrighted etc they are often left out of Blendswap files.


cheers, gryff :)




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...