Jump to content
This forum will be closing down. Please move to the respective dedicated project forums.

Blurred sprites


Edison4
 Share

Recommended Posts

The method you're using for setting the default scale mode is deprecated. The current way to do it is like this:

PIXI.settings.SCALE_MODE = PIXI.SCALE_MODES.NEAREST;

I took a look at the values of the baseTexture on your vulcan sprite, and the scaleMode seems to be set to 1 (nearest), so I think it should be working as-is. Maybe your auto-resizing of the game view is at fault here.

Or maybe setting PIXI.settings.SCALE_MODE has some side effects that will fix the problem. It might help you to take a look at the source in the github repo.

Link to comment
Share on other sites

20 minutes ago, PainKKKiller said:

It may be off topic, but I really wonder why with enabled  setting PIXI.settings.SCALE_MODE = PIXI.SCALE_MODES.NEAREST;

my fonts looks broken. Are there any ways to avoid that?

That's how nearest (point) texture filtering works. If you want smooth filtering use LINEAR instead

http://pixijs.download/release/docs/PIXI.html#.SCALE_MODES

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...