Jump to content

error while running zip contents


Recommended Posts

Hi Folks,

I am downloading the snippet from http://www.babylonjs-playground.com/#55SNLC#9 using zip option. So that i can include it in my project and start working on it.

However i am getting the error on load itself: 'Cannot read property 'isVerticesDataPresent' of undefined.'

Nor do attached camera works. any help would be appreciated. 



Link to comment
Share on other sites

Hey, you're doing well with floorplan maker.  :)

Let's see... This line: if(currentMesh.name == "YesItsMyBox"){

...should change to this: if(currentMesh && currentMesh.name == "YesItsMyBox"){

(that should stop some errors that happen when moving pointer before clicking anything).

Umm... I zipped it, and... unzipped to local drive, and it worked for me (somewhat).  No vertices error.  Perhaps we are using different versions of BJS, or perhaps you need to clear browser cache.   Not sure.  hmm.

Do you see TypeError: t is undefined?  I do.  Mine camera started working after I disabled ALL edgesRenderer lines.  hmmm

Core team MAY have accidentally reverted a previous repair of edgesRenderer.  OR... maybe I HAVE THE OLD BJS VERSION, eh?  heh

Not sure.  Also, you have two attaches.  Make sure you attach camera once (at top of code).  Not sure about your "detach" camera.inputs thing... maybe don't do that.  :)

That's all I have so far.  Report back.  No sign of isVertices error, here, yet.  Still thinking.  :)

Link to comment
Share on other sites

Hi Wingnut,

I have tried clearing cache. also i have not included js on local. i'm pulling all the hosted url, the way zip provides it for you. tried other things you have suggested. none seems to work though. please see the snapshot for scripts that i am using





Link to comment
Share on other sites

Yeah, I'm still editing my last post.  Sorry.

Working on this PG.


Still getting lots of errors caused by currentMesh... still battling.  :)

Camera is working, though.  EdgesRendering turned off.  Feel free to zip it and take it home... fight with it... report discoveries.  :)  Or just copy/paste my mess.  I accidentally removed some radius limits... sorry.

hmm... isVerticesDataPresent of undefined.  hmm.  Boy, that almost sounds like something is taking some time to finish loading, and code is running BEFORE load is finished.  Like something needing to wait for loader onSuccess, or something needing to wait for scene.executeWhenReady... something like that.  Maybe.  I'm not overly smart.  :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...