Jump to content
This forum will be closing down. Please move to the respective dedicated project forums.

Can no longer use mask with TilingSprite?


chib
 Share

Recommended Posts

First of all, hey guys!  I've been floating about the forum for a while now, and look forward to posting a lot more in the near future.

 

I've been having quite a bit of fun playing around with Pixi these last few months, I'm in the midst of developing a game powered by it.  Anyway, I've hit a problem that I thought somebody may be able to help out with;

I was creating mountains by using a TilingSprite masked by a Graphics object, this was working beautifully up until I tried to use another mask somewhere else.  The problem was that the two completely unrelated masks were interfering with one another.  After doing a little research I found that this was a known bug with the WebGL renderer and was fixed in the latest release, however, after downloading and testing the latest release it appears that TilingSprites can no longer be masked?

I have set up a simple test to illustrate the problem: http://danielboa.com/maskTest/
 

Open up the developer console and you will see the error "Uncaught TypeError: Cannot read property 'primitiveShader' of undefined".

 

I tried the same thing but with the Canvas renderer and no error is displayed, but the mask also doesn't seem to have any effect.

 

Hopefully someone more clued up on the WebGL renderer can shed some light on this problem.

Many thanks,
Daniel.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...