Jump to content

Debug Layer Wont Open


Recommended Posts

He everyone, I'm trying to debug my scene but I can't open the debug layer.  I am using Babylonjs 3.3.0-aplha.13



gives this error

The error I get is Please update your browser to open the js inspector in an external view.

I am using google chrome but it is up to date, I get the same error in safari which is also up to date.

When I switch to 


It opens but does not show anything except the black layout.

Any ideas what I can do to get the debug layer working?

Link to comment
Share on other sites

On 8/10/2018 at 4:42 PM, Pryme8 said:

Try a different browser first, yu might have pop ups turned off on your chrome.  (No clue I’m just guessing)

yea that was working for a while but I  believe when I switch the 3.3.0-alpha.13 it stopped working il test it some more today.

I have so far tested safari and chrome, neither worked.  Il update if anything changes.

Link to comment
Share on other sites

Yes there is, I hadn't noticed it sorry. this is the error:

Helpers.ts:144 Uncaught TypeError: Cannot read property 'firstChild' of undefined
    at Function.e.CleanDiv (Helpers.ts:144)
    at e.refresh (Inspector.ts:338)
    at new e (Inspector.ts:228)
    at t._createInspector (babylon.js:30)
    at HTMLScriptElement.n.onload (babylon.js:4)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...