Jump to content

setVerticesData in last version


Recommended Posts

This code:

      this.mesh.setVerticesData(BABYLON.VertexBuffer.PositionKind, positions,  true);      this.mesh.setVerticesData(BABYLON.VertexBuffer.NormalKind, normals, true);      this.mesh.setVerticesData(BABYLON.VertexBuffer.UVKind, uvs, true);      this.mesh.setIndices(indices);         

Does work with Internet Explorer, and doesn't work with Chrome. When I say doesn't work I mean the mesh doesn't appear in the scene.

It happened when I updated to the latest beta version. 

In previous version I worked with (where the setVerticesData had the signature (number[], string, boolean) instead of (string, number[], boolean) )  it worked just well in both browsers.

Link to comment
Share on other sites

Maybe it happens because I have a huge amount of vertices? This is what I have:

  1. IndicesArray[135000]
  2. NormalsArray[68403]
  3. PositionsArray[68403]
  4. UvsArray[45602]

If so, it still doesn't explain why it works with previous version.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...