Jump to content

Yeoman install issue[Solved]


Recommended Posts

Hello Everyone,


Thanks for reading this, I am having issues install the Yeoman scaffolding program and grunt.js. When doing npm install yo -g 

I run into this error. Ive installed Node.js prior to this but still having issues. Any help would be greatly appreciated, I cant afford to rip out anymore of my hair.


Link to comment
Share on other sites

1 hour ago, bruno_ said:

Try to run your command with sudo

Don't do this, you get stuck having to run almost everything with sudo.

Reinstall node properly so you don't have to sudo everything. You can reown a number of directories to solve it but its a ballache, an uninstall and reinstall is by far the easiest solution.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...