Jump to content

[solved] blender export mesh with armature


Recommended Posts

Hi everyone,

When I want to export a mesh with armature from blender I get the "mesh has unapplied transformations.  This will never work for a mesh with an armature." error.

Using the search function I found 2 threads discussing this:

Tried everything suggested there, but I am still stuck. Would be great if you could point me to the right direction!

.blend is attached exporter version 5.2

I thank you in advance!



Link to comment
Share on other sites

Aww crap... I thought I double checked everything...

Sorry and Thanks for your help!


EDIT: Fail save guide (some steps might be unnecessary):

1. select the armature in object mode set all rotations to 0 (not -0) and all scales to 1

2. select the mesh in object mode set all rotations to 0 (not -0) and all scales to 1

3. select the armature in object mode and do object>apply>rotation and scale from the menu

4. do the same for the mesh

5. do steps 1 and 2 again! (I failed to do that)

6. select the mesh in edit mode, set the 3d cursor to your meshes position and resale the mesh using the cursor as pivot point to fit the armature again.

7. export


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...