Jump to content

Phaser 2 Video wont load on android 7.1.1


jonnnn
 Share

Recommended Posts

Hi guys, 

Im kinda new here but I need help with Phaser 2 (PhaserCE 2.10.3) and loading videos.. 
My code is :

main.prototype = {
   preload: function(){
      game.load.video("earth_1", "assets/video/earth_1.mp4");
   },
   create: function(){
    var video = game.add.video("earth_1");
    video.play(true);
    video.addToWorld();

    var flare = spawner.spawn(g.sprites.flare)

    var ring = spawner.spawn(g.sprites.ring)
    var highly_recommended = spawner.spawn(g.sprites.highly_recommended)
    var logo = spawner.spawn(g.sprites.logo)
...


it works fine when I run it in web using a local server.. but when I compile it with cocoon using canvas+, i get an error.
using the cocoon developer app i get the errors attached.. 

i tried my best to google it out and also look at the 
https://photonstorm.github.io/phaser-ce/ docs as well as the main site but i just cant crack this

running out of ideas.. does the video resolution have an effect?

im using an .mp4 video as an animated background

 

Screenshot_2018-04-23-03-51-49-29.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...