V!nc3r

What is the default antialiasing used?

Recommended Posts

If we take this default scene, we can notice that the aliasing is nice & OK: https://www.babylonjs-playground.com/#9R74DF#7

But if on line 32 you enable the pipeline, the result is not quite good (by using the default values of FSAA & MSAA) : https://www.babylonjs-playground.com/#9R74DF#6

So my question is: by default, without renderingPipeline, which aliasing is used? And what settings have we to be tweaked and/or enabled in the pipeline options to get the exact same default aliasing?


Is it also possible to get this default aliasing without using the pipeline? (can be useful when usin colorGrading texture: https://www.babylonjs-playground.com/#9R74DF#8)

Share this post


Link to post
Share on other sites

Hiya V.  I'm not qualified to answer, but can anything be learned from this PG:

https://www.babylonjs-playground.com/#Y3C0HQ#146

During a wide SRC search for 'MSAA', that term popped-up in the What's New doc...

...so I clicked it and found that PG.  :)  Might be useless for ya.  Stay tuned for better answers.

Oh, @trevordev is here... he's a genius and a darned nice guy, too.  I think he created that awesome playground.  Maybe he will visit and teach us something.  Hi T!  Thx T!  :)

Share this post


Link to post
Share on other sites

Hi,

When not using the default pipeline I believe msaa 4x is used but when enabling the default pipeline msaa is off by default (see line 42 samples is set to 1). To get the default pipeline to get the same behavior as no pipeline try setting samples = 4 on line 42. 

To get no aliasing without the default pipeline you can try to set anti aliasing to false in the engine constructor. (See https://doc.babylonjs.com/how_to/optimizing_your_scene)

Hope that helps

Share this post


Link to post
Share on other sites

I up this topic with a question, not sure if it's a bug or me misundertanding something: open this playground in Edge (42.17134.1.0) > https://www.babylonjs-playground.com/#K4S3GU#22

X3zkKcy.gif

It's more visible in the playground than in this gif, bug AA is OK without pipeline, but isn't with pipeline.

So, if the default MSAA is the same than the one in the pipeline, is it a bug here, or something wrong I'm doing?

(also, I've noticed that set pipeline.samples = 1 doesn't show the warning, but still doesn't enable the MSAA.)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.