Jump to content

["SOLVED"]GM: Studio instance_deactivate/activate and other issues


Recommended Posts

Today I was testing a new project and it was working fine on PC but when I tested on Android the graphics where blurred or with artifacts and there was certain errors like object instances not deactivating ( a Game Maker thing that suspends instances rather than destroying them ), objects not being destroyed etc.

So I thought maybe it was just the new project but when I tested everything else on my portfolio same issues. I tried a variety of Android devices old and new with different versions of Android and issues persisted. Finally I went to my one IOS device, the ipod touch 4, and the same thing.


Anyone having this? I am a GameMaker: Studio user BTW. My portfolio is at www.gamesaag.com if anyone wants to see what I'm talking about.

Link to comment
Share on other sites


I "solved" the issue. I am not really sure what it is but all I had to do was change the actions on the object that handles scaling from the step event to the end step event. Apparently on mobile browsers events do not take place in the same order as desktop browsers, or the step event itself, or instance_deactivate/activate actions or any combination. The point is that whatever it was its "fixed" now.

If I could just get rid of this graphics artifacts I'll be very happy but I am quiet content as it is.

Link to comment
Share on other sites

I think this is a rare case of bugs when we work with HTML5. For instance, I found on one of my projects the Alarm 0 would never trigger, but alarm 1 would (I am no GameMaker noob, I was setting the Alarm with a value above 0) and indeed it was frustrating, so some instances I used Alarm 1 instead just because it worked. Some infrequent bugs are popping up... I think if it happens again, best place to post it would be Mantis to load a bug report.


As for the graphics, it may be a display problem. Check to see if the browser itself does not scale the graphics down by themselves to lower quality, I know this happened with my projects as well (Even if it uses HD graphics) and has been rather frustrating.

Link to comment
Share on other sites

Yeah, GameMaker does crazy stuff like that. I did report the bug but by the time I got a reply I had already "solved" the problem.

As for the graphics, my games have a single set of assets and are very low res so they will probably only scale up. I do not use pixel interpolation and set webgl to auto detect. As for scaling I use a modified version of the method shown on the yoyo tutorials. I have always had a bit of artifacts is just that with some games and devices they are more annoying than others.



In case of "rare bugs" try to create a blank project and export old resources to it.


I'll try that next time for sure. Thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...