Jump to content

Why are my normals "soft" ?


Recommended Posts


I've created a entire scene with Maya & Blender and exported it as a .babylon, all maps seems to load well but it also seems like the entire scene has "softened" normals with this soft edge look. 

I've included a Maya and a Babylon playground screenshot to better show the problem.

Thanks !



Link to comment
Share on other sites

Within Blender, you can trigger Flat Shading on the whole scene using the checkbox on the scene properties tab.  For individual meshes, there is a checkbox on the Mesh Data properties tab.

The trade off of doing it in Blender vs on load is Blender requires less coding, but the .blend file will be bigger.  If doing it in Blender causes the # of unique vertices to exceed 32K, you might be better doing it at run time.  Consult your log file to know.  You will be warned if this happens, I think.

As far as flat shading the quads / nGons as opposed to triangle, sorry WebGL only supports triangles.  The export process converts to triangles on a temporary copy of the mesh data very early.  Knowing what the original geometry was is lost.

Link to comment
Share on other sites

On Blender you have to set an edge split modifier and set sharp edges on your geometry, otherwise by default all your meshes will be smoothed.

I don't know the equivalent of this modifier on Maya, in 3dsmax it's called smoothing groups.

Sharp edges are preserved when i export from 3dsmax to Blender using FBX, i assume from maya it will do the same.

[edit] So to summarise if you want import your maya scene to blender :

  • export from maya to fbx, don't know its exporter options, but don't check "triangulate" or "preserve edge orientation" if you want keep quads
  • import fbx to Blender
  • select your objet and set shading to smooth
  • assign edge split modifier, check/uncheck by edge angle if you want
Link to comment
Share on other sites

For the record and to help futurs users :

You can set the edge sharpness in maya using "mesh display -> harden/soften edge" and this setting will be well exported in fbx or obj files.
But even if blender shows it in preview, it is necessary to check the "Flat shade entire scene" checkbox in the exporter options (see attached image).

Anyway thanks everyone for your answers, I'll try to adapt the future geometry to adapt to the fact that triangles are made visible by this method.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...