Jump to content

Model poor quality in babylon


Recommended Posts

I have a model that looks well in Blender and Meshlab, but somehow looses quality when I load it in Babylon. 

The first image is loaded in Babylon. I marked a few examples of the poor quality with red lines. The second image is from Meshlab. As you can see, the Meshlab model has a nice round nose, the nose of the Babylon guy is bumpy. The same goes for the chin, lips, eye holes and more places on the entire model.  

Please note: the original was an FBX, I converted it to STL for loading in Meshlab and .Babylon for Babylon - I am trying to get the STL loaded in Babylon, to see if it is a file format problem or an engine problem. My first guess it is the engine, since both formats use the same representation of the data (ascii) which should not give problems like rounding errors.

(Loading the STL has its own problems. Babylon loaders are reluctant at times to do the work or give proper feedback)




Link to comment
Share on other sites

I fixed the loader problem. Here is a screenshot of the same model but loaded from an STL file - the same file as the Meshlab image shows.

As you can see, this files is of much better quality. So I am afraid there is something with either the Babylon-format, or the Babylon export Blender plugin.





Babylon-Man van STL.png

Edited by Fedor
image wrong
Link to comment
Share on other sites

Flat shading is not usually associated with quality per say.  I am not 100 % sure this is all that you would need to do for a Blender workflow, but you really need to tell the exporter that you wish flat shading for each mesh or the whole export.  If you still have the .blend, please try checking the box prior to export.


Link to comment
Share on other sites

  • 2 weeks later...

Finally got around testing it. The flat shading option seems to allmost double the number of vertices. As far as I can see it gives every face it's own vertices. For me that doesn't work well. 

I did manage to soften the jagged effect edges by increasing the number of faces. It is still not really gone but it doesn't look as bad as it did.


Link to comment
Share on other sites

*nod*  A quick note about flat shading.


That's BJS-style flat-shading on the left.  Normally, only ONE lighting normal is allowed per corner vertex (center picture).

But flat shading (for a box) needs 3 lighting normals at each corner.  It often needs 3 texture UVs at each corner, too (so we can put a different texture on each side).  SO, verts are added... making a mesh about 3 times larger, byte-wise.

BJS boxes are flat shaded by default... they have 24 verts instead of 8.  But other mesh primitives are NOT flat-shaded by default.

I just wanted to show you WHY flat-shaded things... need more verts.  It is so that each face is lit individually.  Otherwise, you would not see the flat-shaded effect.  Be well.

Link to comment
Share on other sites

From a Blender POV, it exports up to 4 decimals, which gets generally good results @ a good file size price.  If your geometry is all < than 1 in size, you might rescale & apply a 10x increase in scale.  This is a matter of degree, If you want hard face-normal dimpling effect, you need to have unique normals at all the vertices for each face.  That disables indexing optimization.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...