Jump to content

Blank screen in WEBGL mode with Chrome on osX Sierra


Regis
 Share

Recommended Posts

Hello!

My game does not render in chrome when I use the AUTO mode. I have the same problem with the Phaser examples that are in AUTO mode.

Everything goes well when I test my game on Safari or on mobile browsers.

Here is my configuration :

macOS Sierra 10.12

chrome 56.0.2924.87 (64-bit)

Does anyone has had the same issue? Any solution (other than configuring the game in CANVAS mode)?

Thank you.

Regis.

Link to comment
Share on other sites

Unfortunately there is nothing in the console.

Chrome on Android has not this problem.

It is stranged because it works well with Chrome on some other iMacs with the same Chrome and macos version.

Also WebGL works well when I test some other "WebGL only" website. So it seems to be phaser related.

However if I inspect the WebGL processing with the "WebGL inspector" Chrome extension, I see that the frame buffer is correctly computed but it seems that it is not rendered in the Chrome browser.

 

Link to comment
Share on other sites

I'm using the exact same version of Chrome and macOS, and the tutorials all load and run normally from localhost. Which means it's not this specific combination causing it, but something else undetermined as well. That could be anything though - GPU blacklist perhaps, a Chrome extension blocking Phaser (I've seen it before), something installed locally, etc.

Start by swapping from AUTO to CANVAS. If that works, the issue is almost certainly GPU related. If the Phaser Examples site works (most of which use WebGL) but it doesn't work locally, then start temporarily disabling Chrome extensions. Maybe there is something like 'https only' or a security scanner getting in the way. It's also entirely possible there is just a bug in that version of Chrome re: your GPU, that no longer manifests in Canary. Which would explain why identical set-ups (except the hardware) don't have the same problem.

Link to comment
Share on other sites

@Regis Did you send a feedback to Chrome? I have already done a couple of time.

Are other WEBGL demos working for you? And what is your Mac model? Mine is Macbook Pro 15' Early 2011.

For example some of WEBGL demos listed at https://www.chromeexperiments.com/webgl are not working either.

https://demo.marpi.pl/spider/

Link to comment
Share on other sites

Thanks Tom.

Here is the result of setting a tint :

58c124eade0e9_Capturedecran2017-03-09a10_47_50.thumb.png.69c44a4e88e15ac813bb9d084020b65f.png

When I set a tint, the first "NaN" disappear from the bufferSubData function but there is still "NaN" in the last parameters. Do you know where they come from?

Also I always have a "Texture 27" rendered at the end of the frame (but it seems to be transparent).

Link to comment
Share on other sites


Hi, @Regis

Can you update your Chrome browser and relaunch the game page? My current Chrome  version is now Version 57.0.2987.98 (64-bit)

Phaser can now disable WebGL support in Chrome so that games work at least.

But WebGL examples stopped working in Chrome on my Mac after the update: https://www.chromeexperiments.com/webgl (it still works on Safari though)

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...