Search the Community

Showing results for tags 'osx'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • HTML5 Game Coding
    • News
    • Game Showcase
    • Facebook Instant Games
    • Web Gaming Standards
    • Coding and Game Design
  • Frameworks
    • Phaser 3
    • Phaser 2
    • Pixi.js
    • Babylon.js
    • Panda 2
    • melonJS
  • General
    • General Talk
  • Business
    • Collaborations (un-paid)
    • Jobs (Hiring and Freelance)
    • Services Offered

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Twitter


Skype


Location


Interests

Found 11 results

  1. Hey, I just upgraded to OSX Sierra and this bit of code does not work anymore on chrome : /* --- Skybox --- */ var skyboxObject = BABYLON.Mesh.CreateBox("skyBox", 10000.0, scene); var skyboxMaterial = new BABYLON.StandardMaterial("skyBox" + sceneKey, scene); skyboxMaterial.backFaceCulling = false; skyboxMaterial.reflectionTexture = new BABYLON.CubeTexture(taskObject.ASSETS_FOLDER + "/textures/fantasy/Sky", scene, ["_px.png", "_py.png", "_pz.png", "_nx.png", "_ny.png", "_nz.png"]); skyboxMaterial.reflectionTexture.coordinatesMode = BABYLON.Texture.SKYBOX_MODE; skyboxMaterial.diffuseColor = new BABYLON.Color3(0, 0, 0); skyboxMaterial.specularColor = new BABYLON.Color3(0, 0, 0); skyboxObject.material = skyboxMaterial; skyboxObject.rotation.x = Math.PI; I get this : Only one side of the cube. No error in the console. I will try to get more information on this, I have been swamped these past few days... sorry. This bug is not present in safari.
  2. Hi anyone got MakeIncremental working on mac osx I get errors about Newtonsoft not found.
  3. Hello! My game does not render in chrome when I use the AUTO mode. I have the same problem with the Phaser examples that are in AUTO mode. Everything goes well when I test my game on Safari or on mobile browsers. Here is my configuration : macOS Sierra 10.12 chrome 56.0.2924.87 (64-bit) Does anyone has had the same issue? Any solution (other than configuring the game in CANVAS mode)? Thank you. Regis.
  4. Anyone seeing a strange white rectangle drawn in the Phaser game canvas in Google Chrome (Version 56.0.2924.87 (64-bit)) WebGL mode on OSX Sierra (10.12.3)? https://phaser.io/examples/v2/buttons/action-on-click I thought that it was just me having the problem. I am not using WebGL / auto as a temporary work around. Other Phaser examples I have seen are working fine.
  5. Hello, I recently found out that my game looks bright (sometimes too bright) only in the desktop Chrome browser (version 53) on OSX (El Capitan). Has anyone gotten similar problems? I checked up few of those Phaser bitmap examples (such as this one) but the examples do not apparently have the color difference issue. I am afraid that I might be doing something wrong with the images or the script. Thank you very much for your advices on this matter in advance. Left : Chrome / Right : Safari P.S. I tried removing color profile from image or choosing different color profiles, which did not solve the problem.
  6. Hi guys ! I just spotted what I think is a bug (or rather a compatibility issue). Here is a *very* simple PG : http://www.babylonjs-playground.com/#27DV4V#6 It only prints the depth map on a plane. Here is a screenshot of the PG with Chrome 52 on Windows 7 : Here is a screenshot of the PG with Safari on an Ipad (iOS 9.2.1) : As you can see, no depth map with Apple, the plane is totally black (or gray with the light here). Maybe are you aware of this issue ? (do I hope too much ? ) Is there a WebGL restriction I don't know with Apple ? I had the chance to run the PG on different Macs and iPhones (different versions also), and the issue appears on every Apple device. I don't own any Apple devices but I can make tests at work if you need them. I would be glad to help if I can. PS: I make some tests and it looks like a simple render target texture with a shader material which computes the depth could work. And it seems like the RTT of the depthRenderer has a lot of different properties than the basic RTT I made.
  7. Hi everybody! I did a configurator for prefabricated houses: http://concept.wec360project.se/arholma10n.php It works fine on Chrome for Windows, Firefox and Safari but the drag and drop function its not working on Chrome for Mac. Here is a video where you can check how it works on other browsers: Here is a video with the errors: I had the same issue in Internet Explorer but I fix it (just for IE) changing: src = evt.dataTransfer.getData ("text / plain"); for: src = evt.dataTransfer.getData ("text"); but on Chrome for Mac this only let me put the first model of window and first model of door (other windows, doors, color function, roof function dont work). I asked a friend in other country to prove it because I dont have mac equipment (its hard to find in my country). How can I fix the drag and drop function for Chrome for mac? Thank you all in advance.
  8. Hi. I'm trying to make a house configurator, the problem I have is that is not working properly on Chrome (latest version) for Mac. You can see a preview version of the configurator in: http://www.wilawara.com/wec360demo/ And it works fine on Windows (Chrome & Firefox) as you can see in: In my country it is not very easy to access Mac equipment so I asked a friend (in other country) to try it in mac but the drag n drop function does not work, you can check the mistakes here: https://www.youtube.com/playlist?list=PLnzWqhLuiuDCtWe0fhr86lqLPcf2-Jn4Z Can someone tell me what I should do to make it work properly on any desktop (or Chrome for Mac min.)? Also can somebody try it on Safari to see if there is the same problem? Thank you very much to all.
  9. Hi all, Another weirdo cross-browser problem I am desperate to fix. A tester running Safari 6.03 (not the most current, but not ancient either), keeps having the game freeze with a strange error: "TypeError: type error" -- it traces back to phaser.min.js line 11 but I'm unable to see what in my code is causing the issue. Is this a known thing? Any advice at all would be appreciated - You guys are the best! Nick
  10. Here's a dilly of a pickle I'm having... I'm using CANVAS as my renderer. The game I'm building works great on Chrome but on Firefox, specifically for OSX, I'm having issues. For instance, a 4GB RAM Intel Core i3 PC running Firefox runs great but a 8GB RAM Intel Core i5 Macbook Pro running Firefox runs laggy... I've tried switching to bitmap fonts and reduce other expensive operations but still... Is there any one who has experienced this or who knows what's going on? (Please spare me the 'PCs are better' jokes ) Nick
  11. WebCode is a vector drawing app for Mac that generates JavaScript+Canvas, CSS+HTML or SVG code. www.webcodeapp.com