Jump to content

New Playground features


Recommended Posts

Hello community!

As you know, the playground is a very valuable tool if you want to try, experiment and share your Babylon scenes. You can even search for a specific word in the whole snippet database from the documentation website, that make it easy to find and discover a new snippet.
And because we know it's a very powerful tool, we worked hard last month with @Deltakosh on a better user experience when searching for playground.
From now on, when saving a new playground, you'll have to fill several information: a title, a description and some tags. It will be asked only once at the playground creation, and all next iterations of this PG will share these metadata. You won't be able to redefine it afterwards. For all PG that don't have any metadata, you will be asked to fill it only once.

The search has also been improved. You can search for a word in the PG code like usual, but you can also search for a word into a PG title/description, or a specific tag. 
The overall quality of search had also been improved (ou can now search with several words, that will return all PG that contain these words, and several bugs have been fixed).

All this work couldn't have been done without @Jaskar and @DeathSoul who wrote all the code (back and front-end), and @Deltakosh of course :) So go try it : http://doc.babylonjs.com/playground

Please helps us by reporting all bugs you can have in this thread :) 

Thank you very much !!


Link to comment
Share on other sites

12 hours ago, javalang said:

Searching the PG by creation-date would be also  a great feature, are there any plans?

We don't have any date information for a playground, so if we do it now it would work only for newer playground. And the use-case is not very clear on my side...

12 hours ago, javalang said:

searching in code is sadly not working inbetween comments and shader-code, can this be enabled?

I don't understand what you're trying to say... Can you give me an example ?

Link to comment
Share on other sites

well, maybe I'm wrong, but if I have no search results if I search a word that exists in the PG, but is quoted. This concerns all comments, urls, ressource-identifiers (imagenames etc.) and shader-code, which is also qouted.

Again, maybe I'm wrong, but on my machine I have either no hits or I'm falling in a timeout.




Link to comment
Share on other sites



And the use-case is not very clear on my side

a use-case could be "restrict my search to the last year / month.. " or "give me the latest playgrounds first". But anyway, better more hits than too less :)


PS: I made some searches again and I still can't find out what the problem could be. Sometimes there is a quick match, even in comments. But search words like "worldViewProjection", "texture2D". "uniform", "sampler2D" , "precision" are never returning with a result (endless loop), but they exist in PG's see #1HWOMR#0 for example

Link to comment
Share on other sites

Aww, these guys will have filtering options by the tons, come month-end.  Regexp, pattern-matching, wildcards, coming soon, I'm sure.  ;)  (Wingy wipes some faerie dust away from his eyes). 

Hey Javalang... you know you have a "TV face", yes?  People with faces like yours... always play the cop, rookie stock car driver, country music singer, or family doctor...  :)  in TV shows.  Need a second career?  Ya got the face for it.  :)  (boy is THAT off-topic, huh?)

My github repo name is wingnutt.  I can code-search for wingnutt, and find all uses of my github url.  So, THAT "within-quotes" test... is working.  Haven't tried searching within shader strings, or searching for multiple words within quotes... yet.  Soon.

I'm losing some playgrounds, here and there.  That has me a bit worried... but I'm sure things will smooth-out.  I think I will backup my "hot" playgrounds to .js files on the localdrive, temporarily, just in case.  Make a 'get .zip' pile, perhaps.  :)

Link to comment
Share on other sites

6 hours ago, javalang said:

PS: I made some searches again and I still can't find out what the problem could be.

Ok I can reproduce this problem, it's linked to another issue... I'll check it this Monday. 

1 hour ago, Wingnut said:

I'm losing some playgrounds, here and there.

It should not happen. Could you point me few PG that are not available anymore ?

Link to comment
Share on other sites

Hi T, good to see you.  http://www.babylonjs-playground.com/#13TVWJ#4

That one was used to help a user in this thread, and I think it had metadata added.  This morning, it's gone or broken.  It appears that the user got the help... before the PG evaporated.

About 2 hours later, I created http://www.babylonjs-playground.com/#11YE88#18

Later in the day, it was lost. (see comments timestamps in that thread)  Notice the crossed-out text?  #18 WAS "just a sphere" (with all other mesh disabled) :)  The replacement version had all mesh enabled.  :)  In other words, I had to adjust the comment.

Same symptom. It tried to load/display #18, but PG reverted to default PG scene.

When I re-saved that (modified #17) PG (without metadata) within that same series, the PG app saved it as #18 (again).  (as if it had never saved an earlier version of #18).   I believe the ORIGINAL #18 was the first PG to which I added metadata).

I think... both times (maybe 3 times) that I entered metadata during a save, the PG still claimed it had no metadata (after the save).

I KNOW I added metadata to one of the bobsled saves from yesterday, too.  I remember giggling at the "title" field.  Wingnut Bobsled (how cutesy, eh?).  But still, the latest version says "no metadata found"... so... THAT metadata save apparently didn't "take" or "carry over" its metadata, it seems.  I think I remember losing a bobsled save, yesterday... but I have so many... that I probably just quickly fixed and re-saved without metadata.

ALSO... had a "BJS2.5 version" PG fail, about 14 hours ago.  See here.  I believe that was attempted WITHOUT metadata.

So, it APPEARS that there might be a problem with the PG saves that include metaD.  Firefox spoken here.

I'll give you more info as I find it... thx for investigating.  Should I open a Q&A thread?  Or perhaps a bug thread?  *shrug*

Link to comment
Share on other sites

Hello everybody !

New features part 2: 
- You can now search any word or part of word (inside/outside of quotes)
- You can ALSO search for shaders available in CYOS ! In this case, results will be displayed in red, and a link will forward to CYOS.
- A version dropdown is available. By default, the link will forward to the last available iteration, but you can change that by selecting another version.
- All bugs for some research (no results, impossible to read the code...) should be fixed now. Please report it if you still have some.

@Wingnut, the PG was under migration on Friday, so it may be possible some PG didn't made it to the new database. If so, please send me the PG ID/iteration in PM and I'll try to recover it.>

Link to comment
Share on other sites

Thanks T! 

I had a problem with BJS 2.5 saves yesterday, still, but I tested one this morning... with mDATA, and it seemed to work PERFECT.

Also, "no metadata" notification is gone, so that is good.  MetaData button works fine, and previously-entered metadata was found within.  PERFECT!

NICE!!!  Thanks again... we're fartin' thru silk, now!  :)

And thanks for the standing-offer for PG recovery-attempts... that's very kind/cool of you.  I'm pretty excited about these new features!  They ROCK!  I've already noticed a 50% efficiency increase... in Q&A custodian ops.  It feels like I have new wizard powers... and I do.  :)

Link to comment
Share on other sites

Hey PG Search Team, I have a feature request, if you are entertaining such things.  See the little magnifying glasses on the RIGHT side of each field?  Well... perhaps a little < button on the left sides.  Its action? 

IF there was a previous search in this input field, (re-)place THAT text back-into the field, and focus.  (for... oops, typing/spelling mistake - got 0 returns)

IF there was no previous search done in this field, clear the field and focus there (just like clicking on the textArea itself).

Generally, I'm seeking a quick/easy way to "edit" my 0-hits due-to-typing-mistake... issues.  The < would indicate "put LAST search-text into field, and focus() there".  Sort-of like a BACK button.  :)  Other ideas welcome, of course.  Thx for consids, guys!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...