Jump to content

Phaser 2.0.7 - Amadicia - Released

Recommended Posts



We're pleased to announce the release of Phaser 2.0.7. This release comes just a week after 2.0.6 but includes some important fixes. Internally we've updated to Pixi 1.6.1 as lots of the fixes come directly from that upgrade, which in turns restores functionality of things like RenderTextures and Retro Fonts. It also fixes strange issues with Buttons and Images.


There's also a vastly improved SpriteBatch included, which has seen batching speed increases of up to 400% in some cases, which is extremely fun to play with (note: batching is a WebGL feature). Plus we've continued to roll in pull requests from the community and fix issues as quickly as we can. You'll notice a number of input related updates in this release, tidying up the handling of Priority IDs and optimising when pixel perfect checks are run. So if you now use a combination of IDs and pixel perfect checks you can easily speed-up the input loop dramatically.


Again thanks to everyone who helped work on this release. The community for reporting issues and pull requests, the team at Goodboy for responding to major Pixi issues quickly and the team here for rolling out another important upgrade.


Hopefully we can now focus on the 2.1 release and enjoying some of this warm weather outside :)

Link to post
Share on other sites

Hello, thanks for the update!

It solved some issues with buttons not switching states properly.

But seems like Image.crop () stopped working...  :ph34r:

Console warning:

'Attr.nodeValue' is deprecated. Please use 'value' instead.


Additionally cropRect and updateCrop () throw runtime error.

Link to post
Share on other sites
  • 2 weeks later...

Works fine for me:

var game = new Phaser.Game(800, 600, Phaser.AUTO, 'phaser-example', { preload: preload, create: create });function preload() {    game.load.atlas('seacreatures', 'assets/sprites/seacreatures_json.png', 'assets/sprites/seacreatures_json.json');    game.load.image('undersea', 'assets/pics/undersea.jpg');}var greenJellyfish;function create() {    game.add.image(0, 0, 'undersea');    greenJellyfish = game.add.sprite(330, 100, 'seacreatures', 'greenJellyfish0000');    game.input.onDown.add(changeFrame, this);}function changeFrame() {    greenJellyfish.frameName = 'greenJellyfish0010';}
Link to post
Share on other sites

since my question about this is already on page 2 i take the liberty to ask here again..

has something changed in 2.0.7 with tiled object layers?

i paint polyline objects in tiled and convert them to physicsbodies in p2.. and get a strange error..


Link to post
Share on other sites

To add to valueerror's question, are there known problems to p2 in this version? I'm finding that removeSprings doesn't work and I'm sure it did in the past. I know that 2.1 includes an update to p2 so I'd just like to know if I should just wait for that or whether there is a change to springs and constraints in 2.07 that can be worked around.

Link to post
Share on other sites

Oh. Maybe I was previously only implementing a single spring and then removing that was removing all springs but I didn't realise as the single one was gone. To the best of my efforts removeSpring does not remove a single spring passed to it.

Should this be posted as a bug to phaser GitHub or p2 GitHub?

I'd love to be able to find and offer a solution but my investigations thus far have not been fruitful.

Link to post
Share on other sites

All removeSpring does is, literally, call the p2 world.removeSpring function:

    removeSpring: function (spring) {        this.world.removeSpring(spring);        this.onSpringRemoved.dispatch(spring);        return spring;    },

That's it. So if it's not working I suspect it may have been an issue in the version of p2 that Phaser uses (which is getting quite old now and will be updated for 2.1)

Link to post
Share on other sites
  • 3 weeks later...

Hello. I am reading "Discover Phaser" by Thomas Palef. In chapter "First Project" I am to copy-paste some code into my code editor. I use NetBeans 8.0 and Phaser Amadicia. The problem is the app does not work, it shows only the string: "My first project with Phaser". Even though I tried other code editors as well, it was all the same. And what's more NetBeans alerts there are mistakes in phaser.min.js and that the variable "Phaser" in main.js is not defined. Please, help me with the issue. What am I doing wrong?

Link to post
Share on other sites

IMHO it would be better to open a separate thread for this and provide some code examples to look at  :)  i'd like to help but i don't know what you actually did.. how your code looks like (because i don't have tho book)

Thank you for response. I think it would be very beneficial. Maybe advanced members will do that. The code as follows:

That is main.js:

var mainState = {preload: function() {// Load the imagegame.load.image('logo', 'logo.png');},create: function() {// Display the image on the screenthis.sprite = game.add.sprite(200, 150, 'logo');},update: function() {// Increment the angle of the sprite by 1, 60 times per secondsthis.sprite.angle += 1;}};var game = new Phaser.Game(400, 300, Phaser.AUTO, 'gameDiv');game.state.add('main', mainState);game.state.start('main');

and that's index.html:

<!DOCTYPE html><html><head><meta charset="utf-8" /><title> First project </title><script type="text/javascript" src="phaser.min.js"></script><script type="text/javascript" src="main.js"></script></head><body><p> My first project with Phaser </p><div id="gameDiv"> </div></body></html>

And 2 more instruments: Phaser.min.js and logo.png


I also couldn't find the way how to add this picture to the IDE from the control panel, thus I did it manually :)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...