Jump to content

Phaser 2.4.5 + 2.4.6 Released


rich
 Share

Recommended Posts

phaser-245-released.png.c300d05df25d4064

Update: 2.4.6 is now out, which addresses 2 severe issues in 2.4.5.

I'm very pleased to announce that after a lot of work Phaser 2.4.5 is now released:

http://phaser.io/news/2016/02/phaser-245-released

There are over 85 improvements across the whole API. From things like Dolby Digital Sound support and integration of the EarCut library, to lots of fixes and documentation updates.

Personally I'm really pleased with this release. After a lot of hard work I managed to get the GitHub issues count down from over 160 issues to just 43, and none of the remaining issues are critical priority. Many thanks to the patrons who support me in doing this (otherwise mostly thankless!) work.

Phaser LTS

Due to on-going development of Lazer, Phaser is soon to enter the LTS (long-term support) stage of its life. This is when we impose a feature freeze, locking the API down and responding only to bugs. This is a necessary step to allow us to focus on Lazer while still ensuring Phaser is given the support it deserves. Thousands of developers use Phaser and we've no intention of ignoring that. However with the release of 2.4.5 we will now be moderating issues opened on GitHub to this effect.

Onwards and upwards :)

Link to comment
Share on other sites

The release looks awesome, sadly I'm getting this error:
Uncaught TypeError: Failed to execute 'drawImage' on 'CanvasRenderingContext2D': The provided value is not of type '(HTMLImageElement or HTMLVideoElement or HTMLCanvasElement or ImageBitmap)'
The second it switches stages, worked on 2.4.4.


Just so you know: I've been an avid open-source person for most of my youngish life. For two reason realistically, first because of the cost... you can pay huge sums and you don't even get it see the source! Reason two: its the whole experience. I have always wanted to make a game, and until recently (past year) never got the whole flow of how it worked. I mostly coded back-end system stuff, so basically I can make a nice secure login but game logic flew out the window for me. Phaser has taught me so much about how many things work, that my respect for your work could not be higher. I mean, I made a game... something I thought was never going to happen besides the few tests and tries I've had over the years.

Now I understand, I'm from New York, money in your pocket does seem better then respect but I do want you to understand I appreciate your work. I have over the years tried to donate / help projects I use a lot ( I'm all about Linux so there are plenty of projects that need help. ), but this vastly depends on how much money I have and it generally comes down to the fact that I have always struggled for money. So I guess what I'm saying is, if I was more well off, I would definitely support Phaser (besides community efforts). Otherwise all I can say is thanks!

Link to comment
Share on other sites

@rgk thanks for the kind comments. re: the error changing states, I'll need a code sample please because I tested it changing states and it works fine (I ran it through all of the Interphase 1 games and they all worked fine, and use states for loading, menu, game), so it must be something more specific, probably to a certain game object.

Link to comment
Share on other sites

Sorry about the delay, the issue is coming from this line of code:
 

renderSession.context.drawImage(this.texture.baseTexture.source, cx, cy, cw, ch, dx, dy, cw / resolution, ch / resolution);

which is line 22706 in phaser.js, otherwise I'm trying to figure out what part of my code is causing this, debugging isn't working quite as well as I thought.

Link to comment
Share on other sites

Whoa, 85 fixes - that's huge. Thank you!

There is an issue with Phaser.Text - some symbols simply don't display. This issue is inconsistent - in 1st case  "Aa" & "Bb" don't display, in another case "Save" and "Edit".

Maybe it is related to the font I use, but it worked in 2.4.4. I will prepare separate test case today.

Буфер обмена-2.png

Буфер обмена-3.png

Link to comment
Share on other sites

Hi Rich!

I'm still getting these:

Phaser v2.4.6 | Pixi.js v2.2.9 | Canvas | WebAudio | http://phaser.io phaser.min.js:11
3Phaser.Loader - active loading canceled / reset phaser.min.js:20
Phaser.Cache.getImage: Key "background" not found in Cache. phaser.min.js:19
Cannot set frameName: autumn phaser.min.js:19
Phaser.Cache.getImage: Key "background" not found in Cache. phaser.min.js:19
Cannot set frameName: autumnGround phaser.min.js:19
Phaser.Cache.getImage: Key "background" not found in Cache. phaser.min.js:19
Uncaught TypeError: Cannot read property 'index' of undefined phaser.min.js:19
Phaser.Loader - active loading canceled / reset phaser.min.js:20

And the game does not work.

Link to comment
Share on other sites

@rich
Thanks 2.4.6 fixed the issue I was having, still not 100% sure what was going on.
I do notice it seems to output some debug info via the line: console.log('generateTilingTexture', texture, frame); via line 16082 in phaser.js
Not sure if that was intended, but its nice debug info non-the-less.

Link to comment
Share on other sites

  • rich unpinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...