Jump to content

Phaser 2.1.3 "Ravinda" is Released


rich
 Share

Recommended Posts

post-1-0-22574800-1414066051.png

 

Hi all,

 

We're pleased to announce the immediate availability of Phaser v2.1.3 "Ravinda". Usually we wouldn't have released this version quite so soon after 2.1.2 but we worked hard with Goodboy Digital to tie it in so we released at exactly the same time as Pixi v2.0.0.

 

Pixi v2 is a huge update - many months of hard work and refactoring. You can read about it in Mats blog post. Phaser 2.1.3 uses Pixi v2 fully through-out and we thankfully did it without breaking any Phaser APIs in the process :) There are also a bunch of new Phaser updates and enhancements as well which you can check on github.

 

You'll also find the new Phaser JSON format documentation in this release. More details here.

 

So all in all, a worthy upgrade :)

 

We're going to switch to Phaser 2.2 development now, which will look at tackling some of the roadmap features such as parallel states.

 

Cheers,

 

Rich

Link to comment
Share on other sites

Quick test in Safari 8 gave me improvements from a swinging 40fps (2.1.0) to a steady 60fps (2.1.3)

 

Interesting about shaders, it always puzzled me how they were not better supported. I have some experience in making shaders for OpenGL, but an example of it in Phaser would be awesome to get started again.

 

Great things are happening :)

Link to comment
Share on other sites

Awesome news, nevertheless bitmaptext is broken. Basically PIXI.BitmapText.call(this, text) is called without style and this is deal breaker in PIXI.BitmapText.updateText which is called from constructor.

 

Yet the BitmapText examples work fine. Yes the constructor is called without the style object, but it doesn't matter because the Pixi constructor in turn calls setStyle which Phaser has replaced with its own override, and that provides all of the correct values it needs. Therefore by the time updateText is hit, the style object is populated correctly.

Link to comment
Share on other sites

I just upgraded to 2.1.3 and when using WebGL the tilemap is rendered once and never again. Everything seems to work fine internally, and I can notice that the game is actually scrolling and the player being followed by the camera, but the tilemap render isn't updating. 

 

I don't see any errors in the console and I haven't changed the code other than replacing phaser.js with the latest build on the master branch. if I switch back to 2.1.2 it works just fine. 

 

Here's a video showing the problem:

Link to comment
Share on other sites

 

I have the same problem with the tilemaps not updating. And the devbranch doesn't fix that for me. I cleared the cache and all.

 
(edit: I guess you didn't update the build folder so that's why there is no change to the .min.js?! ... silly me, how do I make a build to get a fresh phaser.min.js? With grunt?)

 

 

Just type 'grunt' in the root folder of the repo and it'll build a fresh copy for you into the dist folder. If you've never done that before run 'npm install' first.

Link to comment
Share on other sites

 

Pause and Resume works fine in Safari and Chrome on iOS8 for me. Once the mp3 has decoded it plays, pauses and resumes quite happily. If it crashes Safari you should have an actual line number + error, which is it?

 

it's on ios6, it worked before iirc. where do i get line number + error? i am on a pc not a mac.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...